Degraded Performance
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted May 30, 2024 - 19:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 30, 2024 - 14:07 UTC
Investigating
We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted May 30, 2024 - 13:05 UTC
This incident affected: Expensify Website And Mobile App.