Web app not loading, mobile app can't connect
Incident Report for Expensify
Postmortem

Regarding the downtime earlier today... Sorry about that! Totally our fault. ☹️ To provide some clarity on what happened here, a simple human error which remained undetected in code review caused an upgrade to our databases to go down unexpectedly, and also prevented us from immediately bringing them back online. Please be assured that we have taken specific steps to make sure that this type of error can't happen again during future upgrades. While our team was able to identify the issue and restore connectivity relatively quickly, this downtime is below the standard of service that we aim to provide, and we sincerely apologize for any inconvenience this may have caused!

Posted Oct 19, 2018 - 00:30 UTC

Resolved
We've monitored the situation and have confirmed that the web app and mobile apps are working correctly.

Again, we're really sorry for the trouble here, and will be reviewing to confirm how to prevent future issues.
Posted Oct 18, 2018 - 13:48 UTC
Monitoring
We've identified and fixed the underlying causes of our downtime, and are monitoring the site recovering now.
You should be able to use the web app and mobile apps again without interruption.

We're really sorry for this extended down-time, and are going to be working to review the next steps we need to take here.
Posted Oct 18, 2018 - 13:42 UTC
Identified
We've identified the cause of today's site issues, and are currently working on a fix. We're aiming for a fix to be in-place within the next 30 minutes, and for the site and mobile app to recover after that point.

We'll provide an update once that's in place, and again we're really sorry for interrupting your day.
Posted Oct 18, 2018 - 13:01 UTC
Update
We're continuing to investigate what's causing site instability. This is affecting customers trying to use the web app and the mobile apps on iOS and Android (you may not be able to see the full list of your expenses or reports right now).

We're sorry for the interruption of your work day, and are hard at work to get Expensify working properly again. We'll keep updating you with more information here.
Posted Oct 18, 2018 - 12:25 UTC
Investigating
We're currently identifying reports that Expensify's web app is not loading, or is working slowly, for our customers.
Sorry for the trouble here, and we'll provide an update when we have a solution in-place
Posted Oct 18, 2018 - 12:06 UTC
This incident affected: Expensify Website And Mobile App.