Degraded Performance
Incident Report for Expensify
Resolved
Thanks for your patience! Performance is back to normal.
Posted May 09, 2024 - 16:21 UTC
Monitoring
We’re aware of site instability issues, and things have improved over the past day; however, you may experience some intermittent instability, and we're actively working to resolve it.
Posted May 08, 2024 - 20:34 UTC
This incident affected: Expensify Website And Mobile App.