Site outage
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Mar 31, 2023 - 16:41 UTC
Monitoring
We’ve identified the issue causing issues with the site, and have restored core functionality. Some functionality may have reduced performance and we're working to get it corrected as quickly as we can.
Posted Mar 31, 2023 - 14:03 UTC
Update
We are continuing to investigate this issue.
Posted Mar 31, 2023 - 12:51 UTC
Investigating
We're currently experiencing an issue with the site. Our team is aware and working to get it corrected as quickly as we can.
Posted Mar 31, 2023 - 12:36 UTC
This incident affected: Expensify Website And Mobile App.