Company Off-Site, potential delays to support responses outside of US business hours
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 17:27 UTC
Monitoring
The Expensify team is currently at a company off-site, working together for a week to deliver future product development. There may be some delays to customer support interactions and setup assistance (phone, chat and email) outside of US business hours. We appreciate your patience this week, and will try our best to minimise the impact on you and your teams.
Posted Jun 12, 2022 - 22:39 UTC