Blank box when connecting personal cards

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 13:14 UTC

Identified

Our team has identified an issue affecting the connection or fixing of personal card feeds. This applies to Amex US, Chase, Capital One, Bank of America, Wells Fargo and Citi cards connected in personal account settings in Expensify Classic. This does not affect corporate cards connected at the Domain level or commercial feeds. The underlying cause has been identified, and we're working on a fix.
Posted Aug 04, 2025 - 10:13 UTC