Expensify Website And Mobile App Down
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 04:52 UTC
Update
We are continuing to investigate this issue.
Posted Jun 03, 2020 - 04:52 UTC
Investigating
We're currently investigating an issue with our server cluster.
Posted Jun 03, 2020 - 04:50 UTC
This incident affected: Expensify Website And Mobile App.