Support messages not sending in Expensify website
Incident Report for Expensify
Resolved
Our customer support platform provider has fixed this issue now, and you're able to send us messages via our website again! Thanks for your patience here
Posted Nov 13, 2018 - 16:17 UTC
Investigating
Our customer support platform is investigating an issue where messages are failing to send when using the in-app support messenger via our website. If you're having trouble sending us a message there, please just email concierge@expensify.com and we'll be happy to help!
Posted Nov 13, 2018 - 16:08 UTC
This incident affected: Support Message Deliverability.