Citibank Outage
Incident Report for Expensify
Resolved
Thanks for your patience! A fix has been applied and new card connections will work normally. Expenses on current connections might take up to 24 hours to flow back into your account. If you have any gaps in your expense data after that timeframe, please try clicking the Update button on your card connection or reach out to concierge@expensify.com for assistance.
Posted Apr 01, 2020 - 13:54 UTC
Investigating
We are aware of a connection issue with Citibank and are currently working on a fix. New transaction imports and new card connections will not work at this time.

If you would like to upload transactions manually you can do so via the following:
- personal cards: Settings > Account > Credit Card Import > Import transactions from file
- company cards: Settings > Domains > Company Cards > Upload Spreadsheet

We're sorry for any inconvenience here and will update this status as soon as we have more information.
Posted Mar 31, 2020 - 17:34 UTC
This incident affected: Card Import and Feeds (Other Banks).