American Express - Business
Incident Report for Expensify
Resolved
Thanks for your patience! We have a New And Upgraded American Express Business connection available for our customers. If you continue to have any issues, please reach out to concierge@expensify.com.
Posted Aug 18, 2020 - 14:42 UTC
Monitoring
A temporary fix is in place, affected customers should try updating their American Express - Business connections.
Posted Jun 18, 2020 - 08:34 UTC
Identified
Due to changes at American Express, the American Express - Business connection is not importing transaction data at this time. We are working with American Express to resolve the issue.

The American Express - Personal connection is working well and can be used in the interim.
Posted Jun 01, 2020 - 14:52 UTC
This incident affected: Expensify Website And Mobile App and Card Import and Feeds (American Express).