Chase connection currently down.
Incident Report for Expensify
Resolved
Our Chase OFX connection is once again fully functional! Chase resolved a slight change they made on their end that caused this connection disconnect. If you had previously attempted to import/update a Chase card into Expensify, please try again!
Posted Apr 10, 2018 - 22:26 UTC
Investigating
We're currently investigating a major outage with our Chase OFX connection. This connection failure will affect all cards currently imported into Expensify as well as all attempts to import a new card/account. We will update the status as we work to resolve this connection interruption!
Posted Apr 10, 2018 - 15:18 UTC