Site is down
Incident Report for Expensify
Resolved
The site is back up and the incident is resolved.
Posted Mar 30, 2022 - 22:31 UTC
Monitoring
The site is back up. We are monitoring the situation for now.
Posted Mar 30, 2022 - 22:16 UTC
Identified
The issue has been identified and we're implementing a fix.
Posted Mar 30, 2022 - 21:59 UTC
Investigating
We are currently investigating the issue and are working to resume service.
Posted Mar 30, 2022 - 21:52 UTC
This incident affected: Expensify Website And Mobile App.