Delayed Support Responsiveness
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Jul 25, 2019 - 14:29 UTC
Investigating
We apologize for any delays in support responsiveness. Our support responses have been further delayed by Independence Day in the USA, for which all of our US team has the day off. We are continuing to work on clearing the queue and appreciate your continued patience and understanding.

If you have sent in a query, don't worry if you have not received a response in a usual timeframe. We have received your message and will respond as soon as we are able!

Please consult self-service resources such as our help documentation at docs.expensify.com and the Expensify Community at community.expensify.com while you wait. Most questions are already covered in one or both places!
Posted Jul 07, 2019 - 21:24 UTC
This incident affected: Support Message Deliverability.