Expensify is a little slower than usual
Incident Report for Expensify
Resolved
A lot of you loved our commercial (skrrrt - https://www.expensifythis.com/ ), and things are working smoothly again.
Posted Feb 04, 2019 - 00:34 UTC
Monitoring
Hey there, Expensify's web app and mobile app may be working a little slower than usual (Our commercial was pretty popular - https://www.expensifythis.com/ ) but we're keeping an eye on things.
Posted Feb 04, 2019 - 00:22 UTC
This incident affected: Expensify Website And Mobile App.