Delayed Support Responsiveness
Incident Report for Expensify
Resolved
Thanks for your patience! Support Message Deliverability is back to normal.
Posted Jun 28, 2019 - 15:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2019 - 01:51 UTC
Update
We apologize for the continued disruptions in support responsiveness. We are continuing to work on the issue and appreciate your continued patience and understanding.

If you have sent in a query, don't worry if you have not gotten a response in a usual timeframe. We have received your message and will respond as soon as we are able!

Please consult self-service resources such as our help documentation at docs.expensify.com and the Expensify Community at community.expensify.com while you wait. Most questions are already covered in one or both places!
Posted Jun 12, 2019 - 02:36 UTC
Update
We apologize for the continued disruptions in support responsiveness. We are continuing to work on the issue and appreciate your continued patience and understanding.

If you have sent in a query, don't worry if you have not gotten a response in a usual timeframe. We have received your message and will respond as soon as we are able!

Please consult self-service resources such as our help documentation at docs.expensify.com and the Expensify Community at community.expensify.com while you wait. Most questions are already covered in one or both places!
Posted Jun 10, 2019 - 06:50 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 09, 2019 - 10:44 UTC
Update
We are continuing to work on a fix for this issue.

If you have sent in a query, don't worry if you have not gotten a response in a usual timeframe. We have received your message and will respond as soon as we are able!

We recommend checking out resources such as our help documentation at docs.expensify.com and the Expensify Community at community.expensify.com while you wait; most questions are already covered in one or both places!

We appreciate your patience and understanding!
Posted Jun 08, 2019 - 16:34 UTC
Update
We are continuing to work on a fix for this issue.

If you have sent in a query, don't worry if you have not gotten a response in a usual timeframe. We have received your message and will respond as soon as we are able!

We recommend checking out resources such as our help documentation at docs.expensify.com and the Expensify Community at community.expensify.com while you wait; most questions are already covered in one or both places!

We appreciate your patience and understanding!
Posted Jun 07, 2019 - 18:40 UTC
Identified
We've identified delays in typical support message responsiveness, and are working to resolve them as quickly as we can. If you have sent in a query, don't worry if you have not gotten a response in a usual timeframe. We have received your message and will respond as soon as we are able!

We recommend checking out resources such as our help documentation at docs.expensify.com and the Expensify Community at community.expensify.com while you wait; most questions are already covered in one or both places!

We appreciate your patience and understanding!
Posted Jun 07, 2019 - 14:07 UTC
This incident affected: Expensify Website And Mobile App and Support Message Deliverability.