Web app working slower than usual
Incident Report for Expensify
Resolved
Thanks for your patience - the site should be back to normal speed now. We're looking into the root cause to prevent this from happening again in the future. Thanks again!
Posted Dec 03, 2018 - 13:18 UTC
Monitoring
Sorry for the site being slow! We've put a fix in place now and are monitoring the results to confirm that it's working well for you.
Posted Dec 03, 2018 - 13:06 UTC
Investigating
We're currently investigating reports of the web app working slower than usual for our customers.

Sorry for the trouble here, and we'll provide an update when we have a solution in-place.
Posted Dec 03, 2018 - 12:57 UTC
This incident affected: Expensify Website And Mobile App.