Service Outage
Incident Report for Expensify
Resolved
Thanks for your patience! Site performance is back to normal.
Posted Sep 10, 2018 - 21:31 UTC
Identified
We are currently experiencing a site outage. Our team has identified the root cause and is taking corrective action. We apologize for the inconvenience.
Posted Sep 10, 2018 - 21:10 UTC
This incident affected: Expensify Website And Mobile App.