Delays in support request responsiveness
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Oct 10, 2018 - 21:26 UTC
Investigating
We're experiencing significantly higher than normal support requests at this time. As a result, there may be a longer than usual wait time for replies from our support team. We recommend checking our documentation/help pages at docs.expensify.com as well as our Customer Community at community.expensify.com for resources and appreciate everyone's patience in advance.
Posted Oct 02, 2018 - 21:49 UTC
This incident affected: Support Message Deliverability.