Expensify Website And Mobile App down
Incident Report for Expensify
Resolved
Servers back up and running. Site issues resolved!
Posted May 13, 2019 - 15:05 UTC
Monitoring
The site is back up. We're monitoring it closely
Posted May 13, 2019 - 15:02 UTC
Identified
We've identified the issue and are working on the fix now.
Posted May 13, 2019 - 14:58 UTC
Investigating
We're currently investigating an issue with our server cluster.
Posted May 13, 2019 - 14:32 UTC
This incident affected: Expensify Website And Mobile App and Support Message Deliverability.