Expense Merge System Down
Incident Report for Expensify
Resolved
Thanks for your patience! This system has been restored to full functionality.
Posted Jun 06, 2018 - 21:08 UTC
Identified
We have identified an issue that is affecting expense merging. Currently, no expenses can be merged together. We're working diligently to get this resolved as quickly as possible. This status will be updated promptly.
Posted Jun 06, 2018 - 17:32 UTC
This incident affected: Expensify Website And Mobile App.