Expensify Support - Delayed response 3-7 days
Incident Report for Expensify
Resolved
We're really sorry to everyone who has had delayed support over the last week - we're catching up now and are responding much quicker to our customers. Thanks for your patience here
Posted Oct 17, 2019 - 16:08 UTC
Identified
Our apologies! A perfect storm of events has impacted our response times this week. We’re working hard to respond to everyone as soon as possible and we expect to be through the backlog and up to date within a few days.
Posted Oct 09, 2019 - 23:08 UTC
This incident affected: Support Message Deliverability.