Degraded Performance
Incident Report for Expensify
Resolved
Thanks for your patience! Site performance is back to normal.
Posted Apr 18, 2018 - 23:47 UTC
Identified
We’re aware of site instability issues and working on resolving them as soon as possible. We apologize for the inconvenience.
Posted Apr 18, 2018 - 22:59 UTC