Google SSO inactive since 11AM UTC
Incident Report for Expensify
Resolved
Thanks for your patience! Performance is back to normal.
Posted Jun 22, 2021 - 22:47 UTC
Update
We've implemented a temporary fix while we identify the root cause of the outage.
Posted Jun 22, 2021 - 16:58 UTC
Investigating
We're currently experiencing an issue with Google Single Sign-On where users are seeing this error message "Invalid Login or Password". This has been happening since 11am UTC. We are currently investigating this issue.
Posted Jun 22, 2021 - 13:41 UTC
This incident affected: Expensify Website And Mobile App.