Response times may be slower than usual
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Dec 02, 2021 - 20:38 UTC
Monitoring
Support staff in Europe and Australasia may not answer escalated queries as quickly as usual. This should return to normal next week.
Posted Nov 08, 2021 - 12:00 UTC
This incident affected: Support Message Deliverability.